卡饭网 > 其他 > 正文

eclipse中sdk与adt版本不兼容该怎么解决? 三种方法帮你搞定

来源:本站整理 作者:梦在深巷 时间:2016-03-23 13:10:27

安卓开发过程中经常遇到sdk版本adt版本不相符,sdk版本过高的问题,这篇经验帮助你解决这个问题,如果是adt版本过高,请升级sdk,如果出现的错误如下图所示表示sdk版本过高,下面介绍三种方法

方法一:暴力解决办法

1、又快又直接,绝对能用,就是人为的强制把sdk的版本标识成和adt版本相同,首先找到sdk-tools-lib目录下,找到plugin.prop,一般在最后

2、找到之后右键选择记事本方式打开,打开后把里边的版本号改成adt的版本号

3、重启eclipse,发现没有错误

方法二:在线升级

1、找到eclipse的上方的window-preferences

2、找到左边的Install/Update,Available Software,可以看到adt的更新地址,如果没有请添加一条,地址是http://dl-ssl.google.com/android/eclipse/,注意是http,保存退出

3、再找到eclipse上方的help,check for updates

4、如果一直在读条但没有更新出来,那么说明无法连接google的更新网址,网址被拦截,可以手动修改host解析文件

5、打开c盘下windows\system32\drivers\etc,找到host文件

6、用记事本打开,在最后一行输入网址对应的ip203.208.46.146,如下图所示,保存,重启eclipse再更新

方法三:离线更新。

如果前面还是不能更新,可以离线下载adt的zip压缩包,选择在eclipse离线安装,在上方help-install newsoftware,选择local,找到下载的adt离线包,绑定,然后重启eclipse就没问题了。

相关推荐