卡饭网 > 交换机 > 正文

交换机如何配置RIP

来源:本站整理 作者:梦在深巷 时间:2016-08-25 20:23:48

一、组网要求

配置RIP,使得PC1、PC2能相互通信。

二、组网拓扑

三、配置要点

  • 根据规划,在设备接口上配置IP地址
  • 启动RIP进程,指定版本2,关闭自动汇总,把相关的接口放入RIP进程

四、配置步骤

注意:配置之前建议使用 Ruijie#show interface status查看接口名称,常用接口名称有FastEthernet(百兆)、GigabitEthernet(千兆)和TenGigabitEthernet(万兆),以下配置以千兆接口为例

1)根据规划,在设备接口上配置IP地址

SWA的配置

Ruijie>enable                   ------>进入特权模式

Ruijie#configure terminal        ------>进入全局配置模式

Ruijie(config)# interface GigabitEthernet 0/18    ------>配置与sw2的互连地址

Ruijie(config-GigabitEthernet 0/18)#no switchport ------>把接口属性改成路由接口

Ruijie(config-GigabitEthernet 0/18)#ip address 10.1.1.9 255.255.255.252

Ruijie(config)# vlan 2    ------>创建vlan 2

Ruijie(config)# interface VLAN 2    ------>配置vlan 的网关地址

Ruijie(config-vlan 2)# ip address 192.168.2.254 255.255.255.0

Ruijie(config)#interface GigabitEthernet 0/24    ------>把接口划入到vlan 2

Ruijie(config-GigabitEthernet 0/24)#switchport access vlan 2

SWB的配置

Ruijie(config)#interface GigabitEthernet 0/1   ------>配置与SWA互连的地址

Ruijie(config-GigabitEthernet 0/1)#no switchport

Ruijie(config-GigabitEthernet 0/1)#ip address 10.1.1.10 255.255.255.252

Ruijie(config)#interface GigabitEthernet 0/2     ------>配置与SWC互连地址

Ruijie(config-FastEthernet 0/2)#no switchport

Ruijie(config-FastEthernet 0/1)#ip address 10.1.1.5 255.255.255.252

SWC的配置

Ruijie(config)#interface GigabitEthernet 0/1    ------>配置与SWB互连地址

Ruijie(config-GigabitEthernet 0/1)#no switchport

Ruijie(config-GigabitEthernet 0/1)#ip address 10.1.1.6 255.255.255.252

Ruijie(config)#vlan 10   ------>创建vlan 10

Ruijie(config)#interface VLAN 10

Ruijie(config-Vlan 10)#ip address 172.16.10.254 255.255.255.0

Ruijie(config)#interface GigabitEthernet 0/24

Ruijie(config-GigabitEthernet 0/24)#switchport access vlan 10

2)启动RIP进程,指定版本2,关闭自动汇总

SWA的配置:

Ruijie(config)#router rip    ------>开启Rip进程

Ruijie(config-router)#version 2   ------>启用V2版本

Ruijie(config)#network 10.1.1.8 0.0.0.3    ------>network  ip网段   反掩码(掩码+反掩码=255.255.255.255)

Ruijie(config)#network 192.168.2.0 0 0.0.0.255

Ruijie(config)#no auto-summary     ------>关闭自动汇总功能

SWB的配置:

Ruijie(config)#router rip

Ruijie(config-router)#version 2

Ruijie(config-router)#network 10.1.1.8 0.0.0.3

Ruijie(config-router)#network 10.1.1.0 0.0.0.3

Ruijie(config-router)#no auto-summary

SWC的配置:

Ruijie(config)#router rip

Ruijie(config-router)#version 2

Ruijie(config-router)#network 10.1.1.0 0.0.0.3

Ruijie(config-router)#network 172.16.10.0 0.0.0.255

Ruijie(config-router)#no auto-summary

4)保存配置

Ruijie(config-router)#end

Ruijie#write     ----->  确认配置正确,保存配置

五、验证命令:

SW1验证:

Ruijie# show ip route

Codes:  C - connected, S - static, R - RIP, B - BGP

O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default

Gateway of last resort is 172.16.1.2 to network 0.0.0.0

S*   0.0.0.0/0 [1/0] via 172.16.1.2

R    10.1.1.4/30 [120/1] via 10.1.1.10, 00:15:52, GigabitEthernet 0/18      ------>R 标识的路由条目是通过RIP学习到的

C    10.1.1.8/30 is directly connected, GigabitEthernet 0/18

C    10.1.1.9/32 is local host.

C    172.16.1.0/24 is directly connected, GigabitEthernet 0/14

C    172.16.1.1/32 is local host.

R    172.16.10.0/24 [120/2] via 10.1.1.10, 00:05:30, GigabitEthernet 0/18

C    192.168.2.0/24 is directly connected, VLAN 2

C    192.168.2.254/32 is local host.

PC 1 ping  PC 2

正在 Ping 172.16.10.1 具有 32 字节的数据:

来自 172.16.10.1 的回复: 字节=32 时间<1ms TTL=61

来自 172.16.10.1 的回复: 字节=32 时间=24ms TTL=61

来自 172.16.10.1 的回复: 字节=32 时间<1ms TTL=61

来自 172.16.10.1 的回复: 字节=32 时间<1ms TTL=61

相关推荐