卡饭网 > 交换机 > 正文

锐捷交换机如何配置策略路由(PBR)

来源:本站整理 作者:梦在深巷 时间:2016-08-25 21:36:22

一、组网要求

1) 三层交换机的192.168.2.0/24网段访问外网固定走172.16.1.1这条线

2)三层交换机的192.168.3.0/24网段访问外网固定走172.16.2.1这条线

二、组网拓扑

三、配置要点

  • 配置vlan划分、接口地址、划分相应接口到相应vlan里;
  • 配置访问控制列表,指定流量
  • 配置策略路由图
  • 在接口调用
  • 策略路由的优先级高于静态路由和默认路由。

三、配置步骤

注意:配置之前建议使用 Ruijie#show interface status查看接口名称,常用接口名称有FastEthernet(百兆)、GigabitEthernet(千兆)和TenGigabitEthernet(万兆),以下配置以千兆接口为例。

1) 配置vlan划分、接口地址、划分相应接口到相应vlan里

新建vlan 2、3

Ruijie>enable

Ruijie#configure terminal

Ruijie(config)#vlan 2  ----->创建 vlan 2

Ruijie(config-vlan)#exit

Ruijie(config)#vlan 3

Ruijie(config-vlan)#exit

划分接口到相应vlan下

Ruijie(config)#interface GigabitEthernet 0/1

Ruijie(config-if-GigabitEthernet 0/1)# switchport access vlan 2  ----->把交换机的第一个千兆接口划入到vlan 2

Ruijie(config)#interface GigabitEthernet 0/2

Ruijie(config-if-GigabitEthernet 0/2)# switchport access vlan 3

配置vlan2和vlan3的svi口地址(vlan 网关地址)

Ruijie(config)#interface vlan 2

Ruijie(config-if-VLAN 2)#ip address 192.168.2.254 255.255.255.0

Ruijie(config-if-VLAN 2)#exit

Ruijie(config)#interface vlan 3

Ruijie(config-if-VLAN 3)#ip address 192.168.3.254 255.255.255.0

Ruijie(config-if-VLAN 3)#exit

配置路由口地址

Ruijie(config)# interface GigabitEthernet 0/3

Ruijie(config-if-GigabitEthernet 0/3)#  no switchport

Ruijie(config-if-GigabitEthernet 0/3)#ip address 172.16.1.1 255.255.255.0

Ruijie(config)#interface GigabitEthernet 0/4

Ruijie(config-if-GigabitEthernet 0/4)#no switchport

Ruijie(config-if-GigabitEthernet 0/4)#ip address 172.16.2.1 255.255.255.0

2)配置访问控制列表,指定数据流量

Ruijie(config)#access-list 100 permit ip 192.168.2.0 0.0.0.255 any   ----->匹配 源地址是192.168.2.0/24 ,目的地址是任意的数据包

Ruijie(config)#access-list 101 permit ip 192.168.3.0 0.0.0.255 any

3)配置策略路由图

Ruijie(config)#route-map ruijie permit 10   ----->创建名为 ruijie 的路由图,序列号是10(越小越先匹配)

Ruijie(config-route-map)#match ip address 100   ----->条件:匹配 ACL 100

Ruijie(config-route-map)#set ip next-hop 172.16.1.2   ----->动作:数据包发到 172.16.1.2

Ruijie(config)#route-map ruijie permit 20

Ruijie(config-route-map)#match ip address 101

Ruijie(config-route-map)#set ip next-hop 172.16.2.2

4)在接口调用

Ruijie(config)#interface VLAN 2

Ruijie(config-if-VLAN 2)#ip policy route-map ruijie   ----->在VLAN 2的网关上应用

Ruijie(config)#interface VLAN 3

Ruijie(config-if-VLAN 3)#ip policy route-map ruijie

5) 保存配置

Ruijie(config)#end

Ruijie#write       ----->确认配置正确,保存配置

四、验证命令

Ruijie(config)#show route-map ruijie

route-map ruijie, permit, sequence 10

Match clauses:

ip address 100

Set clauses:

ip next-hop 172.16.1.2

route-map ruijie, permit, sequence 20

Match clauses:

ip address 101

Set clauses:

ip next-hop 172.16.2.2

相关推荐